В контроллерах Schneider Electric обнаружена опасная уязвимость

1

Проблема приводит к отказу в обслуживании устройства.

Программируемые логические контроллеры (ПЛК) Schneider Electric Modicon содержат уязвимость, воспользовавшись которой злоумышленники могут вызвать отказ в обслуживании устройства.

Уязвимость (CVE-2019-6819) затрагивает следующие продукты: Modicon M340 (с версиями прошивки младше 3.01), Modicon M580 (версии до 2.80), Modicon Quantum (все версии прошивки), Modicon Premium (все версии прошивки). Баг может быть проэксплуатирован путем отправки специально сформированного кадра (frame) Modbus на уязвимое устройство.

Производитель устранил уязвимость в серии Modicon M340 с выпуском версии прошивки 3.01, для устройств Modicon M580 доступна исправленная версия прошивки 2.80. Поскольку решение Modicon Quantum исчерпало срок службы, Schneider Electric рекомендует пользователям перейти на более современный продукт – Modicon M580 ePAC.