В программных комплексах CODESYS V3 и CODESYS Control V3 исправлены опасные уязвимости

0

Одна из проблем позволяет извлечь важную информацию, включая учетные данные.

В инструментальных программных комплексах промышленной автоматизации CODESYS V3 и CODESYS Control V3 от компании 3S-Smart Software Solutions GmbH обнаружены опасные уязвимости, позволяющие извлечь важную информацию, включая учетные данные, или скрыть источник вредоносных пакетов.

Самая опасная уязвимость ( CVE-2018-10612 ) выявлена в решении CODESYS Control V3 (оценена в 9,8 баллов из 10 по шкале CVSS v3). Проблема существует из-за отключенного по умолчанию шифрования, что предоставляет злоумышленнику возможность получить доступ к устройству и хранящейся на нем информации, в том числе учетным данным. Уязвимость затрагивает следующие решения: Control для BeagleBone, CODESYS Control для BeagleBone, CODESYS Control для emPC-A/iMX6, CODESYS Control для IOT2000, CODESYS Control для Linux, CODESYS Control для PFC100, CODESYS Control для PFC200, CODESYS Control для Raspberry Pi, CODESYS Control RTE V3, CODESYS Control RTE V3 (для Beckhoff CX), CODESYS Control Win V3, CODESYS V3 Simulation Runtime, CODESYS Control V3 Runtime System Toolkit и CODESYS HMI V3. Проблема устранена в версии ПО 3.5.14.0.

Решение CODESYS V3 содержит две уязвимости – CVE-2018-20025 и CVE-2018-20026. Первая связана с наличием слабых случайных значений, которые могут повлиять на конфиденциальность и целостность данных, а вторая существует из-за некорректного ограничения коммуникационных каналов, что позволяет скрыть источник коммуникационных пакетов. Степень опасности CVE-2018-20025 оценена в 9,4 балла по классификации CVSS v3, CVE-2018-20026 – в 5,8 балла.

Исправленная версия приложения доступна на сайте производителя.