Мир: Пользователям WordPress рекомендуют установить новую версию Download Manager

0

WordPress рекомендует своим пользователям произвести обновление программы Download Manager до версии Download Manager 2.7.5 в связи с обнаружением опасной уязвимости в плагине.


Брешь была обнаружена специалистами компании Sucuri. По словам ее представителя – Майкла Наду, в плагине использовался особый метод обработки AJAX-запросов, который хакеры использовали для вызова произвольных функций внутри контекста приложения. Так как перед обработкой AJAX вызовов проверка прав не производилась, то злоумышленники могли внедрить бэкдор в ресурс или изменить пароль администратора в том случае, если имя учетной записи известно.

По словам Наду, атака может быть осуществлена только в том случае, если хакер сгенерирует действительный одноразовый код (nonce), который используется для идентификации специфической операции, выполняемой пользователем. Однако, поскольку в контексте приложения может выполняться любая функция, то злоумышленником может быть легко вызван фрагмент кода, генерирующего действительный nonce. (WordPress/NovostIT)