Системы ЧПУ Siemens SINUMERIK содержат опасные уязвимости

0

Наиболее опасная позволяет вывести из строя межсетевой экран или выполнить код в его контексте.

Специалисты ICS-CERT предупредили о наличии ряда опасных уязвимостей в решении Siemens SINUMERIK, предоставляющих возможность вызвать отказ в обслуживании, повысить привилегии или выполнить произвольный код. Уязвимыми являются следующие продукты: SINUMERIK 808D v4.7 (все версии) SINUMERIK 808D v4.8 (все версии), SINUMERIK 828D v4.7 (все версии до v4.7 SP6 HF1), SINUMERIK 840D sl v4.7 (все версии до v4.7 SP6 HF5), SINUMERIK 840D sl v4.8 (все версии до v4.8 SP3).

В общей сложности в Siemens SINUMERIK выявлено 10 уязвимостей, наиболее опасная (CVE-2018-11466) из них (оценена в 10 баллов из 10 по шкале CVSS v3) позволяет вывести из строя встроенный межсетевой экран или выполнить код в его контексте.

Остальные уязвимости предоставляют возможность выполнить код с привилегированными разрешениями (CVE-2018-11457, CVE-2018-11458), вызвать отказ в обслуживании VNC-сервера (CVE-2018-11464), инициировать выполнение кода с правами суперпользователя (CVE-2018-11459), запустить код в режиме ядра (CVE-2018-11465), а также выполнить код с повышенными привилегиями (CVE-2018-11461, CVE-2018-11459, CVE-2018-11463). Степень опасности проблем варьируется от 5,3 до 9,8 баллов по классификации CVSS v3.

Компания Siemens уже выпустила обновления для ряда затронутых продуктов, в частности, SINUMERIK 828D v4.7 (обновление v4.7 SP6 HF1), SINUMERIK 840D sl v4.7 (v4.7 SP6 HF5), SINUMERIK 840D sl v4.8 (v4.8 SP3). Обновления для остальных версий решения будут доступны несколько позже.